After fresh installation of Visual Studio Code I decided install Python extension, but faced with an error "Unable to open 'Extension: Python': XHR failed.".
IT blog. Interesting tips and researches of AI, Security, Open Source, Microsoft Exchange and etc.
11 September 2020
24 May 2020
Exchange 2016 - High CPU utilization by Microsoft Exchange Replication Service (MSExchangeMailboxReplication)
I had faced with that issue on my work and with Microsoft support we found the core issue and solved it.
Unfortunately, I haven't been able to reproduce this issue in my home lab, but I'll try to describe all main points.
Procmon was showing that "MSExchangeMailboxReplication.exe" process always (hundreds of times per second) try to open (RegOpenKey) "HKLM\SOFTWARE\Microsoft\ExchangeServer\v15\ActiveManager\TestOverride" reg key.
Adding the "TestOverride" registry key doesn't solve the problem. The process started to searching other keys.
03 May 2020
Exchange 2016 - Issues with ECP/OWA after installing updates/KB
For several reasons after installation updates/KB (for example KB4536987) you may faced with some backfires. I collected 3 type of issues and their fixes.
After authentication on ECP page you may see only text and hyperlinks without any images and styles.
Issue #1 - Lack os styles on ECP page
After authentication on ECP page you may see only text and hyperlinks without any images and styles.
How to fix
Run the script "C:\Program Files\Microsoft\Exchange Server\V15\Bin\UpdateCas.ps1" or do following manual steps:
- Go to "C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\ecp" folder and find the folder with latest version number of your server (e.g. "15.1.1913.7") and it will be empty.
- Open folder with previous version number (e.g. "15.1.1913.5") and copy all data to the new folder (e.g. "15.1.1913.7").
- Restart IIS. Reload the ECP page.
Ярлыки:
ECP,
Exchange,
ExchangeInstallDir,
Issue,
Microsoft.Exchange.Common,
owa
05 April 2020
Analysis of Xiaomi YI camera connections
I have Xiaomi YI (YHS-113) camera at home and once I was wondering what servers does it connects to and what information it transmits. I had caught camera traffic on my router while it was booting and working.
Analysis revealed the following:
- Camera tried to connect to more than 20 servers.
- A part of connection is TCP, and other part is UDP.
- Not all connections were established (a part of servers didn't answer).
- Most of servers are in China, but several servers are in Amazon Cloud.
- Camera transfers to the "log.xiaoyi.com" server information about settings and WiFi name & ssid (see below).
- Camera checks is your router is Xiaomi Router or not.
- Connection to the "api.xiaoyi.com" server is secured by HTTPS with TLS 1.2.
04 April 2020
Windows 10 - Error 30800 / The server name cannot be resolved / SMB & NetBIOS issue
Can not connect to a network drive/shared folder?
Can not print any document on a network printer?
Error #30800 in the Event Log (Application and Services Logs - Microsoft - Windows - SMBClient - Connectivity)?
The server name cannot be resolved.
Error: The requested interface is not supported.
Server name: x.x.x.x
Guidance:
The client cannot resolve the server address in DNS or WINS. This issue often manifests immediately after joining a computer to the domain, when the client's DNS registration may not yet have propagated to all DNS servers. You should also expect this event at system startup on a DNS server (such as a domain controller) that points to itself for the primary DNS. You should validate the DNS client settings on this computer using IPCONFIG /ALL and NSLOOKUP.
Can not print any document on a network printer?
Error #30800 in the Event Log (Application and Services Logs - Microsoft - Windows - SMBClient - Connectivity)?
The server name cannot be resolved.
Error: The requested interface is not supported.
Server name: x.x.x.x
Guidance:
The client cannot resolve the server address in DNS or WINS. This issue often manifests immediately after joining a computer to the domain, when the client's DNS registration may not yet have propagated to all DNS servers. You should also expect this event at system startup on a DNS server (such as a domain controller) that points to itself for the primary DNS. You should validate the DNS client settings on this computer using IPCONFIG /ALL and NSLOOKUP.
04 February 2020
Brief analysis of iCal structure
In my work, I occasionally have to deal with various issues with meeting invitations (encoding troubles, wrong time zone, etc.), so I wanted to understand the structure of iCal (iCalendar).
This is not a complete overview of iCalendar features (RFC2445, RFC2446 and RFC2447). You can get acquainted with the most complete functional overview on the following sites: https://www.w3.org/2000/01/foo & https://www.kanzaki.com/docs/ical/
The analysis involved 8 different iCal emails from Microsoft Exchange 2016 + Microsoft Outlook 2016 environment. Microsoft Exchange adds additional "X-MICROSOFT" and "X-MS-OLK" headers to increase Microsoft Outlook functionality. Fully description you can find there.
In the image below, I tried to clearly visualize links between the iCal file parameters and Outlook interface.
This is not a complete overview of iCalendar features (RFC2445, RFC2446 and RFC2447). You can get acquainted with the most complete functional overview on the following sites: https://www.w3.org/2000/01/foo & https://www.kanzaki.com/docs/ical/
The analysis involved 8 different iCal emails from Microsoft Exchange 2016 + Microsoft Outlook 2016 environment. Microsoft Exchange adds additional "X-MICROSOFT" and "X-MS-OLK" headers to increase Microsoft Outlook functionality. Fully description you can find there.
In the image below, I tried to clearly visualize links between the iCal file parameters and Outlook interface.
22 December 2019
VMware vCenter Server 6.7 Update 3 can TLS in SMTP (STARTTLS)
Working with vCenter Server for a long time, recently in a first time I faced with the need to use secure SMTP session by TLS. And I was confused when I found that it not supported (in 2019!) - https://kb.vmware.com/s/article/2063147
I opened the ticket in VMware support and they said that it works in the latest updates, but the article still not updated.
I tested it on VMware vCenter Server 6.7 Update 3 (14367737) and it really works!
I opened the ticket in VMware support and they said that it works in the latest updates, but the article still not updated.
I tested it on VMware vCenter Server 6.7 Update 3 (14367737) and it really works!
21 December 2019
Powershell script: Outlook To Exchange connection test
Outlook can lose connection with Exchange for various reasons and even if it happened once, it still can impact the business. To help administrators identify the core of an issue I wrote this Powershell script.
The script is designed for Outlook 2013-2019 clients that connected to Exchange 2016-2019 by "MAPI over HTTP" protocol.
Before start the script change two variables:
$Exchange = "exchange.test.local"
$SMTPDomain = "test.local"
The result is presented as an HTML page.
The script is designed for Outlook 2013-2019 clients that connected to Exchange 2016-2019 by "MAPI over HTTP" protocol.
Before start the script change two variables:
$Exchange = "exchange.test.local"
$SMTPDomain = "test.local"
The result is presented as an HTML page.
Ярлыки:
Exchange,
mapi over http,
Outlook,
powershell,
script
12 October 2019
Windows 10 - Recovery / Error code 0xc0000185 / BCD / BitLocker
Recently I suddenly (I thought so) faced with a problem of booting my PC. Windows 10 (LTSB 1607) can't start and shows Recovery blue screen with an error "Your PC needs to be repaired. File: 0xc0000185\EFI\MICROSOFT\BOOT\BCD. Error code: 0xc0000185".
None of the tips from the Internet (e.g. http://www.pcerror-fix.com/solved-windows-10-boot-configuration-data-error-code-0xc0000185) didn't help me (there was no recovery point; bootrec doesn't identified Windows Installation).
None of the tips from the Internet (e.g. http://www.pcerror-fix.com/solved-windows-10-boot-configuration-data-error-code-0xc0000185) didn't help me (there was no recovery point; bootrec doesn't identified Windows Installation).
03 August 2019
VMware vSphere: comparison of Paravirtual and LSI SCSI adapters
You may know that VMware vSphere offers several types of SCSI adapters for virtual machines depending on the OS. The main types are "LSI Logic SAS" and "VMware Paravirtual". There are a lot of articles on this topic (e.g. https://blogs.vmware.com/vsphere/2014/02/vscsi-controller-choose-performance.html). But the real comparison of the performance I saw once, but it's a bit outdated (ESXi 5.0 and Windows Server 2008R2).
Therefore, I did my tests (although not on the latest versions of OS) and compare IOPS, Latency and CPU usage. As a load generator used IO meter 1.1.0.
Therefore, I did my tests (although not on the latest versions of OS) and compare IOPS, Latency and CPU usage. As a load generator used IO meter 1.1.0.
Subscribe to:
Posts (Atom)






